{"id":4370,"date":"2022-10-12T12:47:17","date_gmt":"2022-10-12T19:47:17","guid":{"rendered":"https:\/\/SUMMALAI.COM\/?p=4370"},"modified":"2022-10-12T12:47:19","modified_gmt":"2022-10-12T19:47:19","slug":"how-to-block-potentially-unwanted-applications-pua-with-defender-smartscreen","status":"publish","type":"post","link":"https:\/\/SUMMALAI.COM\/?p=4370","title":{"rendered":"How to Block Potentially Unwanted Applications (PUA) With Defender SmartScreen"},"content":{"rendered":"\n<h3 class=\"wp-block-heading\" id=\"enable-pua-protection-in-chromium-based-microsoft-edge\">Enable PUA protection in Chromium-based Microsoft Edge<\/h3>\n\n\n\n<p>Although potentially unwanted application protection in Microsoft Edge (Chromium-based, version 80.0.361.50) is turned off by default, it can easily be turned on from within the browser.<\/p>\n\n\n\n<ol class=\"wp-block-list\"><li>In your Edge browser, select the ellipses, and then choose&nbsp;<strong>Settings<\/strong>.<\/li><li>Select&nbsp;<strong>Privacy, search, and services<\/strong>.<\/li><li>Under the&nbsp;<strong>Security<\/strong>&nbsp;section, turn on&nbsp;<strong>Block potentially unwanted apps<\/strong>.<\/li><\/ol>\n\n\n\n<h3 class=\"wp-block-heading\" id=\"block-urls-with-microsoft-defender-smartscreen\"><a href=\"https:\/\/learn.microsoft.com\/en-us\/microsoft-365\/security\/defender-endpoint\/detect-block-potentially-unwanted-apps-microsoft-defender-antivirus?view=o365-worldwide#block-urls-with-microsoft-defender-smartscreen\"><\/a>Block URLs with Microsoft Defender SmartScreen<\/h3>\n\n\n\n<p>In Chromium-based Edge with PUA protection turned on, Microsoft Defender SmartScreen protects you from PUA-associated URLs.<\/p>\n\n\n\n<p>Security admins can&nbsp;<a href=\"https:\/\/learn.microsoft.com\/en-us\/DeployEdge\/configure-microsoft-edge\">configure<\/a>&nbsp;how Microsoft Edge and Microsoft Defender SmartScreen work together to protect groups of users from PUA-associated URLs. There are several&nbsp;<a href=\"https:\/\/learn.microsoft.com\/en-us\/DeployEdge\/microsoft-edge-policies#smartscreen-settings\">group policy settings<\/a>&nbsp;explicitly for Microsoft Defender SmartScreen available, including&nbsp;<a href=\"https:\/\/learn.microsoft.com\/en-us\/DeployEdge\/microsoft-edge-policies#smartscreenpuaenabled\">one for blocking PUA<\/a>. In addition, admins can&nbsp;<a href=\"https:\/\/learn.microsoft.com\/en-us\/microsoft-edge\/deploy\/available-policies?source=docs#configure-windows-defender-smartscreen\">configure Microsoft Defender SmartScreen<\/a>&nbsp;as a whole, using group policy settings to turn Microsoft Defender SmartScreen on or off.<\/p>\n\n\n\n<p>Although Microsoft Defender for Endpoint has its own blocklist based upon a data set managed by Microsoft, you can customize this list based on your own threat intelligence. If you&nbsp;<a href=\"https:\/\/learn.microsoft.com\/en-us\/microsoft-365\/security\/defender-endpoint\/manage-indicators?view=o365-worldwide\">create and manage indicators<\/a>&nbsp;in the Microsoft Defender for Endpoint portal, Microsoft Defender SmartScreen respects the new settings.<\/p>\n\n\n\n<h2 class=\"wp-block-heading\" id=\"microsoft-defender-antivirus-and-pua-protection\"><a href=\"https:\/\/learn.microsoft.com\/en-us\/microsoft-365\/security\/defender-endpoint\/detect-block-potentially-unwanted-apps-microsoft-defender-antivirus?view=o365-worldwide#microsoft-defender-antivirus-and-pua-protection\"><\/a>Microsoft Defender Antivirus and PUA protection<\/h2>\n\n\n\n<p>The potentially unwanted application (PUA) protection feature in Microsoft Defender Antivirus can detect and block PUA on endpoints in your network.<\/p>\n\n\n\n<p>&nbsp;Note<\/p>\n\n\n\n<p>This feature is available in Windows 11, Windows 10, Windows Server 2022, Windows Server 2019, and Windows Server 2016.<\/p>\n\n\n\n<p>Microsoft Defender Antivirus blocks detected PUA files and any attempts to download, move, run, or install them. Blocked PUA files are then moved to quarantine. When a PUA file is detected on an endpoint, Microsoft Defender Antivirus sends a notification to the user (<a href=\"https:\/\/learn.microsoft.com\/en-us\/microsoft-365\/security\/defender-endpoint\/configure-notifications-microsoft-defender-antivirus?view=o365-worldwide\">unless notifications have been disabled<\/a>&nbsp;in the same format as other threat detections. The notification is prefaced with&nbsp;<code>PUA:<\/code>&nbsp;to indicate its content.<\/p>\n\n\n\n<p>The notification appears in the usual&nbsp;<a href=\"https:\/\/learn.microsoft.com\/en-us\/microsoft-365\/security\/defender-endpoint\/microsoft-defender-security-center-antivirus?view=o365-worldwide\">quarantine list within the Windows Security app<\/a>.<\/p>\n\n\n\n<h2 class=\"wp-block-heading\" id=\"configure-pua-protection-in-microsoft-defender-antivirus\"><a href=\"https:\/\/learn.microsoft.com\/en-us\/microsoft-365\/security\/defender-endpoint\/detect-block-potentially-unwanted-apps-microsoft-defender-antivirus?view=o365-worldwide#configure-pua-protection-in-microsoft-defender-antivirus\"><\/a>Configure PUA protection in Microsoft Defender Antivirus<\/h2>\n\n\n\n<p>You can enable PUA protection with&nbsp;<a href=\"https:\/\/learn.microsoft.com\/en-us\/mem\/intune\/protect\/device-protect\">Microsoft Intune<\/a>,&nbsp;<a href=\"https:\/\/learn.microsoft.com\/en-us\/mem\/configmgr\/protect\/deploy-use\/endpoint-protection\">Microsoft Endpoint Configuration Manager<\/a>,&nbsp;<a href=\"https:\/\/learn.microsoft.com\/en-us\/azure\/active-directory-domain-services\/manage-group-policy\">Group Policy<\/a>, or via&nbsp;<a href=\"https:\/\/learn.microsoft.com\/en-us\/powershell\/module\/defender\/?preserve-view=true&amp;view=win10-ps\">PowerShell cmdlets<\/a>.<\/p>\n\n\n\n<p>You can also use PUA protection in audit mode to detect potentially unwanted applications without blocking them. The detections are captured in the Windows event log. PUA protection in audit mode is useful if your company is conducting an internal software security compliance check and you&#8217;d like to avoid any false positives.<\/p>\n\n\n\n<h3 class=\"wp-block-heading\" id=\"use-intune-to-configure-pua-protection\"><a href=\"https:\/\/learn.microsoft.com\/en-us\/microsoft-365\/security\/defender-endpoint\/detect-block-potentially-unwanted-apps-microsoft-defender-antivirus?view=o365-worldwide#use-intune-to-configure-pua-protection\"><\/a>Use Intune to configure PUA protection<\/h3>\n\n\n\n<p>See&nbsp;<a href=\"https:\/\/learn.microsoft.com\/en-us\/intune\/device-restrictions-configure\">Configure device restriction settings in Microsoft Intune<\/a>&nbsp;and&nbsp;<a href=\"https:\/\/learn.microsoft.com\/en-us\/intune\/device-restrictions-windows-10#microsoft-defender-antivirus\">Microsoft Defender Antivirus device restriction settings for Windows 10 in Intune<\/a>&nbsp;for more details.<\/p>\n\n\n\n<h3 class=\"wp-block-heading\" id=\"use-configuration-manager-to-configure-pua-protection\"><a href=\"https:\/\/learn.microsoft.com\/en-us\/microsoft-365\/security\/defender-endpoint\/detect-block-potentially-unwanted-apps-microsoft-defender-antivirus?view=o365-worldwide#use-configuration-manager-to-configure-pua-protection\"><\/a>Use Configuration Manager to configure PUA protection<\/h3>\n\n\n\n<p>PUA protection is enabled by default in the Microsoft Endpoint Manager (Current Branch).<\/p>\n\n\n\n<p>See&nbsp;<a href=\"https:\/\/learn.microsoft.com\/en-us\/configmgr\/protect\/deploy-use\/endpoint-antimalware-policies#real-time-protection-settings\">How to create and deploy antimalware policies: Scheduled scans settings<\/a>&nbsp;for details on configuring Microsoft Endpoint Manager (Current Branch).<\/p>\n\n\n\n<p>For System Center 2012 Configuration Manager, see&nbsp;<a href=\"https:\/\/learn.microsoft.com\/en-us\/previous-versions\/system-center\/system-center-2012-R2\/hh508770(v=technet.10)#BKMK_PUA\">How to Deploy Potentially Unwanted Application Protection Policy for Endpoint Protection in Configuration Manager<\/a>.<\/p>\n\n\n\n<p>&nbsp;Note<\/p>\n\n\n\n<p>PUA events blocked by Microsoft Defender Antivirus are reported in the Windows Event Viewer and not in Microsoft Endpoint Configuration Manager.<\/p>\n\n\n\n<h3 class=\"wp-block-heading\" id=\"use-group-policy-to-configure-pua-protection\"><a href=\"https:\/\/learn.microsoft.com\/en-us\/microsoft-365\/security\/defender-endpoint\/detect-block-potentially-unwanted-apps-microsoft-defender-antivirus?view=o365-worldwide#use-group-policy-to-configure-pua-protection\"><\/a>Use Group Policy to configure PUA protection<\/h3>\n\n\n\n<ol class=\"wp-block-list\"><li>Download and install&nbsp;<a href=\"https:\/\/www.microsoft.com\/download\/details.aspx?id=103507\">Administrative Templates (.admx) for Windows 11 October 2021 Update (21H2)<\/a><\/li><li>On your Group Policy management computer, open the&nbsp;<a href=\"https:\/\/learn.microsoft.com\/en-us\/previous-versions\/windows\/it-pro\/windows-server-2008-R2-and-2008\/cc731212(v=ws.11)\">Group Policy Management Console<\/a>.<\/li><li>Select the Group Policy Object you want to configure, and then choose&nbsp;<strong>Edit<\/strong>.<\/li><li>In the&nbsp;<strong>Group Policy Management Editor<\/strong>, go to&nbsp;<strong>Computer configuration<\/strong>&nbsp;and select&nbsp;<strong>Administrative templates<\/strong>.<\/li><li>Expand the tree to&nbsp;<strong>Windows Components<\/strong>&nbsp;&gt;&nbsp;<strong>Microsoft Defender Antivirus<\/strong>.<\/li><li>Double-click&nbsp;<strong>Configure detection for potentially unwanted applications<\/strong>.<\/li><li>Select&nbsp;<strong>Enabled<\/strong>&nbsp;to enable PUA protection.<\/li><li>In&nbsp;<strong>Options<\/strong>, select&nbsp;<strong>Block<\/strong>&nbsp;to block potentially unwanted applications, or select&nbsp;<strong>Audit Mode<\/strong>&nbsp;to test how the setting works in your environment. Select&nbsp;<strong>OK<\/strong>.<\/li><li>Deploy your Group Policy object as you usually do.<\/li><\/ol>\n\n\n\n<h3 class=\"wp-block-heading\" id=\"use-powershell-cmdlets-to-configure-pua-protection\"><a href=\"https:\/\/learn.microsoft.com\/en-us\/microsoft-365\/security\/defender-endpoint\/detect-block-potentially-unwanted-apps-microsoft-defender-antivirus?view=o365-worldwide#use-powershell-cmdlets-to-configure-pua-protection\"><\/a>Use PowerShell cmdlets to configure PUA protection<\/h3>\n\n\n\n<h4 class=\"wp-block-heading\" id=\"to-enable-pua-protection\"><a href=\"https:\/\/learn.microsoft.com\/en-us\/microsoft-365\/security\/defender-endpoint\/detect-block-potentially-unwanted-apps-microsoft-defender-antivirus?view=o365-worldwide#to-enable-pua-protection\"><\/a>To enable PUA protection<\/h4>\n\n\n\n<p>PowerShellCopy<\/p>\n\n\n\n<pre class=\"wp-block-code\"><code>Set-MpPreference -PUAProtection Enabled\n<\/code><\/pre>\n\n\n\n<p>Setting the value for this cmdlet to&nbsp;<code>Enabled<\/code>&nbsp;turns on the feature if it has been disabled.<\/p>\n\n\n\n<h4 class=\"wp-block-heading\" id=\"to-set-pua-protection-to-audit-mode\"><a href=\"https:\/\/learn.microsoft.com\/en-us\/microsoft-365\/security\/defender-endpoint\/detect-block-potentially-unwanted-apps-microsoft-defender-antivirus?view=o365-worldwide#to-set-pua-protection-to-audit-mode\"><\/a>To set PUA protection to audit mode<\/h4>\n\n\n\n<p>PowerShellCopy<\/p>\n\n\n\n<pre class=\"wp-block-code\"><code>Set-MpPreference -PUAProtection AuditMode\n<\/code><\/pre>\n\n\n\n<p>Setting&nbsp;<code>AuditMode<\/code>&nbsp;detects PUAs without blocking them.<\/p>\n\n\n\n<h4 class=\"wp-block-heading\" id=\"to-disable-pua-protection\"><a href=\"https:\/\/learn.microsoft.com\/en-us\/microsoft-365\/security\/defender-endpoint\/detect-block-potentially-unwanted-apps-microsoft-defender-antivirus?view=o365-worldwide#to-disable-pua-protection\"><\/a>To disable PUA protection<\/h4>\n\n\n\n<p>We recommend keeping PUA protection turned on. However, you can turn it off by using the following cmdlet:<\/p>\n\n\n\n<p>PowerShellCopy<\/p>\n\n\n\n<pre class=\"wp-block-code\"><code>Set-MpPreference -PUAProtection Disabled\n<\/code><\/pre>\n\n\n\n<p>Setting the value for this cmdlet to&nbsp;<code>Disabled<\/code>&nbsp;turns off the feature if it has been enabled.<\/p>\n\n\n\n<p>For more information, see&nbsp;<a href=\"https:\/\/learn.microsoft.com\/en-us\/microsoft-365\/security\/defender-endpoint\/use-powershell-cmdlets-microsoft-defender-antivirus?view=o365-worldwide\">Use PowerShell cmdlets to configure and run Microsoft Defender Antivirus<\/a>&nbsp;and&nbsp;<a href=\"https:\/\/learn.microsoft.com\/en-us\/powershell\/module\/defender\/index\">Defender Antivirus cmdlets<\/a>.<\/p>\n\n\n\n<h2 class=\"wp-block-heading\" id=\"view-pua-events-using-powershell\"><a href=\"https:\/\/learn.microsoft.com\/en-us\/microsoft-365\/security\/defender-endpoint\/detect-block-potentially-unwanted-apps-microsoft-defender-antivirus?view=o365-worldwide#view-pua-events-using-powershell\"><\/a>View PUA events using PowerShell<\/h2>\n\n\n\n<p>PUA events are reported in the Windows Event Viewer, but not in Microsoft Endpoint Manager or in Intune. You can also use the&nbsp;<code>Get-MpThreat<\/code>&nbsp;cmdlet to view threats that Microsoft Defender Antivirus handled. Here&#8217;s an example:<\/p>\n\n\n\n<p>ConsoleCopy<\/p>\n\n\n\n<pre class=\"wp-block-code\"><code>CategoryID       : 27\nDidThreatExecute : False\nIsActive         : False\nResources        : {webfile:_q:\\Builds\\Dalton_Download_Manager_3223905758.exe|http:\/\/d18yzm5yb8map8.cloudfront.net\/\n                    fo4yue@kxqdw\/Dalton_Download_Manager.exe|pid:14196,ProcessStart:132378130057195714}\nRollupStatus     : 33\nSchemaVersion    : 1.0.0.0\nSeverityID       : 1\nThreatID         : 213927\nThreatName       : PUA:Win32\/InstallCore\nTypeID           : 0\nPSComputerName   :\n<\/code><\/pre>\n\n\n\n<h2 class=\"wp-block-heading\" id=\"get-email-notifications-about-pua-detections\"><a href=\"https:\/\/learn.microsoft.com\/en-us\/microsoft-365\/security\/defender-endpoint\/detect-block-potentially-unwanted-apps-microsoft-defender-antivirus?view=o365-worldwide#get-email-notifications-about-pua-detections\"><\/a>Get email notifications about PUA detections<\/h2>\n\n\n\n<p>You can turn on email notifications to receive mail about PUA detections.<\/p>\n\n\n\n<p>See&nbsp;<a href=\"https:\/\/learn.microsoft.com\/en-us\/microsoft-365\/security\/defender-endpoint\/troubleshoot-microsoft-defender-antivirus?view=o365-worldwide\">Troubleshoot event IDs<\/a>&nbsp;for details on viewing Microsoft Defender Antivirus events. PUA events are recorded under event ID&nbsp;<strong>1160<\/strong>.<\/p>\n\n\n\n<h2 class=\"wp-block-heading\" id=\"view-pua-events-using-advanced-hunting\"><a href=\"https:\/\/learn.microsoft.com\/en-us\/microsoft-365\/security\/defender-endpoint\/detect-block-potentially-unwanted-apps-microsoft-defender-antivirus?view=o365-worldwide#view-pua-events-using-advanced-hunting\"><\/a>View PUA events using advanced hunting<\/h2>\n\n\n\n<p>If you&#8217;re using&nbsp;<a href=\"https:\/\/learn.microsoft.com\/en-us\/microsoft-365\/security\/defender-endpoint\/microsoft-defender-endpoint?view=o365-worldwide\">Microsoft Defender for Endpoint<\/a>, you can use an advanced hunting query to view PUA events. Here&#8217;s an example query:<\/p>\n\n\n\n<p>ConsoleCopy<\/p>\n\n\n\n<pre class=\"wp-block-code\"><code>DeviceEvents\n| where ActionType == \"AntivirusDetection\"\n| extend x = parse_json(AdditionalFields)\n| project Timestamp, DeviceName, FolderPath, FileName, SHA256, ThreatName = tostring(x.ThreatName), WasExecutingWhileDetected = tostring(x.WasExecutingWhileDetected), WasRemediated = tostring(x.WasRemediated)\n| where ThreatName startswith_cs 'PUA:'\n<\/code><\/pre>\n\n\n\n<p>To learn more about advanced hunting, see&nbsp;<a href=\"https:\/\/learn.microsoft.com\/en-us\/microsoft-365\/security\/defender-endpoint\/advanced-hunting-overview?view=o365-worldwide\">Proactively hunt for threats with advanced hunting<\/a>.<\/p>\n\n\n\n<h2 class=\"wp-block-heading\" id=\"exclude-files-from-pua-protection\"><a href=\"https:\/\/learn.microsoft.com\/en-us\/microsoft-365\/security\/defender-endpoint\/detect-block-potentially-unwanted-apps-microsoft-defender-antivirus?view=o365-worldwide#exclude-files-from-pua-protection\"><\/a>Exclude files from PUA protection<\/h2>\n\n\n\n<p>Sometimes a file is erroneously blocked by PUA protection, or a feature of a PUA is required to complete a task. In these cases, a file can be added to an exclusion list.<\/p>\n\n\n\n<p>For more information, see\u00a0<a href=\"https:\/\/learn.microsoft.com\/en-us\/microsoft-365\/security\/defender-endpoint\/configure-extension-file-exclusions-microsoft-defender-antivirus?view=o365-worldwide\">Configure and validate exclusions based on file extension and folder location<\/a>.<\/p>\n\n\n\n<p>Ref: <a href=\"https:\/\/learn.microsoft.com\/en-us\/microsoft-365\/security\/defender-endpoint\/detect-block-potentially-unwanted-apps-microsoft-defender-antivirus?view=o365-worldwide\">Block potentially unwanted applications with Microsoft Defender Antivirus | Microsoft Learn<\/a><\/p>\n","protected":false},"excerpt":{"rendered":"<p>Enable PUA protection in Chromium-based Microsoft Edge Although potentially unwanted application protection in Microsoft Edge (Chromium-based, version 80.0.361.50) is turned off by default, it can easily be turned on from within the browser. In your Edge browser, select the ellipses, and then choose&nbsp;Settings. Select&nbsp;Privacy, search, and services. Under the&nbsp;Security&nbsp;section, turn on&nbsp;Block potentially unwanted apps. Block <a class=\"read-more\" href=\"https:\/\/SUMMALAI.COM\/?p=4370\">Read More<\/a><\/p>\n","protected":false},"author":2,"featured_media":0,"comment_status":"closed","ping_status":"closed","sticky":false,"template":"","format":"standard","meta":{"_bbp_topic_count":0,"_bbp_reply_count":0,"_bbp_total_topic_count":0,"_bbp_total_reply_count":0,"_bbp_voice_count":0,"_bbp_anonymous_reply_count":0,"_bbp_topic_count_hidden":0,"_bbp_reply_count_hidden":0,"_bbp_forum_subforum_count":0,"om_disable_all_campaigns":false,"_monsterinsights_skip_tracking":false,"_monsterinsights_sitenote_active":false,"_monsterinsights_sitenote_note":"","_monsterinsights_sitenote_category":0,"footnotes":""},"categories":[10,14],"tags":[1334,1333,1335],"class_list":["post-4370","post","type-post","status-publish","format-standard","hentry","category-microsoft","category-windows-7-8-10","tag-block-pua","tag-block-urls-with-microsoft-defender-smartscreen","tag-enable-pua-protection-on-microsoft-edge"],"aioseo_notices":[],"_links":{"self":[{"href":"https:\/\/SUMMALAI.COM\/index.php?rest_route=\/wp\/v2\/posts\/4370","targetHints":{"allow":["GET"]}}],"collection":[{"href":"https:\/\/SUMMALAI.COM\/index.php?rest_route=\/wp\/v2\/posts"}],"about":[{"href":"https:\/\/SUMMALAI.COM\/index.php?rest_route=\/wp\/v2\/types\/post"}],"author":[{"embeddable":true,"href":"https:\/\/SUMMALAI.COM\/index.php?rest_route=\/wp\/v2\/users\/2"}],"replies":[{"embeddable":true,"href":"https:\/\/SUMMALAI.COM\/index.php?rest_route=%2Fwp%2Fv2%2Fcomments&post=4370"}],"version-history":[{"count":1,"href":"https:\/\/SUMMALAI.COM\/index.php?rest_route=\/wp\/v2\/posts\/4370\/revisions"}],"predecessor-version":[{"id":4371,"href":"https:\/\/SUMMALAI.COM\/index.php?rest_route=\/wp\/v2\/posts\/4370\/revisions\/4371"}],"wp:attachment":[{"href":"https:\/\/SUMMALAI.COM\/index.php?rest_route=%2Fwp%2Fv2%2Fmedia&parent=4370"}],"wp:term":[{"taxonomy":"category","embeddable":true,"href":"https:\/\/SUMMALAI.COM\/index.php?rest_route=%2Fwp%2Fv2%2Fcategories&post=4370"},{"taxonomy":"post_tag","embeddable":true,"href":"https:\/\/SUMMALAI.COM\/index.php?rest_route=%2Fwp%2Fv2%2Ftags&post=4370"}],"curies":[{"name":"wp","href":"https:\/\/api.w.org\/{rel}","templated":true}]}}